Author Topic: SCI0 - Is the Template broken for togglesound?  (Read 393 times)

0 Members and 1 Guest are viewing this topic.

Offline Doan Sephim

SCI0 - Is the Template broken for togglesound?
« on: February 05, 2021, 02:21:44 PM »
I just noticed I can't seem to change the audio volume of the snd resources I'm using in the game and the menubar's toggle for sound doesn't seem to do anything (nor does the manual gauge for setting volume)

I'm using MT-32 as the SCI-synth in Companion and as the driver, if that matters.


Artificial Intelligence Competition

Offline gumby

Re: SCI0 - Is the Template broken for togglesound?
« Reply #1 on: February 06, 2021, 06:30:16 PM »
This may be what you are looking for: Fixing F2 (ToggleSound) issue with Companion
In the Great Underground Empire (Zork port in development)
Winter Break 2012 Rope Prop Competition

Offline Doan Sephim

Re: SCI0 - Is the Template broken for togglesound?
« Reply #2 on: February 07, 2021, 09:13:59 PM »
This may be what you are looking for: Fixing F2 (ToggleSound) issue with Companion
Thanks. I saw that post earlier and have made the suggested changes, but it doesn't seem to do anything.

As far as I can tell, I'm not even able to change any volume settings at all at this point, so I'm not sure it's really the toggle that's broken. The volume gauge doesn't yield any change in volume either. I guess I could try different drivers.

Ok...I tried the MPUMIDI driver and the volume works (and the toggle as well). So I'm guessing there's something about the MT32 driver that it doesn't like?


SMF 2.0.14 | SMF © 2017, Simple Machines
Simple Audio Video Embedder

Page created in 0.25 seconds with 25 queries.