Author Topic: Music/Playing Note Sticks When Leaving a Room  (Read 443 times)

0 Members and 1 Guest are viewing this topic.

Offline gumby

Re: Music/Playing Note Sticks When Leaving a Room
« Reply #15 on: June 19, 2019, 09:45:18 AM »
I tried loading up SCI Audio to play around; will it work despite being SCI Script when the rest of the game is Sierra script?  I had some difficulty with it, but may just need to play with it more.  I can try to convert it, but it's size still worries me a bit, even the second, smaller iteration.

I started working on changing the syntax to use Sierra script, but I don't think I ever got it finished.  It's a memory hog for sure, specifically because of the array used to pass commands.
In the Great Underground Empire (Zork port in development)
Winter Break 2012 Rope Prop Competition

Offline troflip

Re: Music/Playing Note Sticks When Leaving a Room
« Reply #16 on: June 19, 2019, 01:13:36 PM »
I tried messing with some other drivers, as well, but what exactly needs to be done to work with these?  ADL.drv just doesn't give me sound;

The key is that the right tracks need to be enabled for each sound driver in SCI Companion's sound editor (top left of the sound editor).

I feel like this lingering note problem has been discussed and solved before, but my memory fails...
Check out my website: http://icefallgames.com
Groundhog Day Competition

Offline Collector

Re: Music/Playing Note Sticks When Leaving a Room
« Reply #17 on: June 19, 2019, 08:31:44 PM »
I do know that some tried to solve the couldn't initialize the hardware error by swapping drivers from other games from near the same era. This often lead to the hanging note. I think we discussed this when the SCI1.1 template game was being developed.
KQII Remake Pic

Offline NilG

Re: Music/Playing Note Sticks When Leaving a Room
« Reply #18 on: June 20, 2019, 05:34:09 PM »
I've tried enabling all tracks for all driver options and all tracks within just the AdLib option in SCIC, but am still running into troubles with both ADL and SNDBLAST.  Am I right in thinking that the SNDBLAST driver works with ADL set tracks?  I did also install the GM Midi/Ad Lib patch Gumby uploaded here some time ago, although I think that's more to improve mapping, rather than to fix any complete lack of sound?

There's only one other instrument I've found that's sticking, so I broke and changed it to an acoustic guitar for now.  The first chunk/part/demo's done, a little QA aside, so that works to at least share what I've got.  Definitely going to take some time to figure out what I'm doing wrong here, though.


SMF 2.0.14 | SMF © 2017, Simple Machines
Simple Audio Video Embedder

Page created in 0.147 seconds with 24 queries.