Author Topic: NAGI is not working properly on Windows 10  (Read 389 times)

0 Members and 3 Guests are viewing this topic.

Offline Kawa

Re: NAGI is not working properly on Windows 10
« Reply #15 on: August 27, 2020, 03:18:31 AM »
I had no SDL.DLL nor interestingly NAGI's font files in my SQ0R folder. It wouldn't run at all without them, of course. Not with a broken image, but not even a window.

Offline Collector

Re: NAGI is not working properly on Windows 10
« Reply #16 on: August 27, 2020, 08:12:45 AM »
The original download on the Virtual Broomcloset included all of the NAGI files. The big ZIP with all of the fan AGI games that was circulating on the net several years ago does as well as does the one on the AGI Wiki. Not sure who was distributing your incomplete archive.
KQII Remake Pic

Offline Kawa

Re: NAGI is not working properly on Windows 10
« Reply #17 on: August 27, 2020, 09:27:13 AM »
It doesn't really matter. The mess in the OP is not to blame on using SDL2 when it needs SDL1.

Offline AGKorson

Re: NAGI is not working properly on Windows 10
« Reply #18 on: August 27, 2020, 11:48:50 AM »
SDL2.DLL is not drop-in compatible with SDL.DLL. You likely wouldn't even get an application window if you tried.

I didn't even think of that, thx for pointing it out. I've been doing some reading on SDL to see if I can use it in next version of WinAGI. Obviously I still have a lot to learn!  ;D


SMF 2.0.14 | SMF © 2017, Simple Machines
Simple Audio Video Embedder

Page created in 0.085 seconds with 25 queries.