Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - amirkle

Pages: [1] 2
1
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 13, 2018, 03:47:42 AM »
ok, that's the one. couldn't get the info regarding memory usage though, not by pressing "i" for memory indicator at least...

got any thoughts? does that stack trace tell you anything?

2
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 12, 2018, 10:02:23 AM »

- what's the stack trace when the crash occurs?
- have you established that it's the addition of one more inventory item that's causing the problem, instead of that *specific* inventory item?

So many easy things you can do to help root cause the problem.

It's very weird... it's not that one specific item that causes the problem. the game crashes the moment i got a 39th inventory item in my inventory script. it works fine with 38 items (potential items, cause the game wont start at all with a list of 39, even when none has been taken on game)

im very sorry for my ignorance, but what is the stack trace and where can i find it?

also, how do i see my memory usage?

3
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 05:20:01 PM »
Doesn't the debug build of the interpreter have stack trace functionality? What's the stack trace? Should be an easy way to narrow down what's causing the problem.

Kawa's suggestion that something bad happened which resulted in trying to call an object with a ridiculous selector seems reasonable. As for what the root cause of *that* would be, my random guesses are:
- Some bug in SCI Companion's compiler
- Some kind of out of memory thing because you're using so much memory with inventory items (which are loaded all the time)
- Some bug in your new inventory item (pretty easily ruled out by removing other items and keeping your new item in)

Yeah, I guess the problem has got to do with over-usage of memory.
wish there was a way to go around it, or to enlarge the possible memory usage. I guess i'll just have to figure out a way to cut on inventory items somehow and finish the game as long as i still have some memory to rely on...

unless you guys have any idea as to how to solve the issue otherwise?

4
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 03:44:04 PM »
ok, got it!

does this one mean anything to you?

I also get this one:

5
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 03:38:22 PM »
ok, got it!

does this one mean anything to you?

6
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 03:24:55 PM »
well, when I try to open the file I get a message it can't run on my pc. When I try to open it as an administrator it says it can't find it..

7
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 02:58:40 PM »
also, after crashing, i get this message:

"Timed out trying to start debugging functionality. This requires a compatible template game." at the output box

8
SCI Community How To's & Tutorials / Re: Inventory problem
« on: December 10, 2018, 02:56:05 PM »
E_BAD_SELECTOR. Try running the game on a debug build (attached) so you can see the full error: "'%s' is not a selector for %s.".

Also, how many items is many?

It works with as many as 38 Inv items. the 39th crashes the game...
can't run the file you sent for some reason.

9
SCI Community How To's & Tutorials / Inventory problem
« on: December 10, 2018, 01:51:23 PM »
Hello friends. I've been working on my game for a year and a half now. It's been a slow process, 'cause I'm working solo, plus I have no background in programming, so it's like walking through a dark forest with a dying candle...  But i'm pulling through.

I came across a scary point today, though: after adding an inventory item to the inventory script, my game wouldn't load anymore. i get an error no. 5 (have no clue what it means). the game works fine if i delete the new inventory item, which makes me suspect i got too many items on my inventory list. problem is, i can't possibly make it to the end of the game without adding at least 10 more items. Got the story in my head and all, and i'm afraid I've come to a dead end. Let me say I DO have a lot of items on the Inv list, and that my scripts are badly written, the outcome of not coming from the programming world and not knowing any effective codes. I'm improvising as i go, and the game is pretty long already. I can actually smell the end, but without adding some more Inv items... probably can't be done.   please, any tips??

10
well i donno.. im nowhere near that size! my resource.000 is 6876 bytes.
i figured it happens when i compile-all. not always, though. sometimes i compile all and im good. sometimes it crashes. when i just use regular compile, im ok. has never crashed...

11
And ffs don't just overwrite your backups!

yeah but how many backups can you have??!?!?! lol

12
I think the only way to diagnose this is to send me the project folder when this happens, and I can try to look at the contents of the resource.map and resource.000 and see how they're out of sync. Also take note of the timestamp of the two files (they should be written at the same time - if the timestamps are different then that's a clue that the issue is that one of the files couldn't be written for some reason.

That'd be great, if you could take a look!
ill send it over if it happens again.. up till now its been ok, keeping my fingers crossed... :)

Thanks a lot though!

13
i got Avira and ESET, but i dont think they should cause any problem...
strange

14
Does this happen after you save a particular resource? Which version of SCI Companion are you using?

Are there any .bak files in your game's folder? When saving, SCI Companion writes out the new resource map and volume to resource.map.bak and resource.000.bak respectively. Then it copies them over the originals and deletes the bak. The volume file is copied first, then the resource map. If something interferes with the second one (maybe some anti-virus software, or the game currently running - but the latter usually prevents the volume file from being written, so it would fail early and you'll be ok), then you'll get mismatched map and volume files, but then presumably there should be a resource.map.bak file laying around which could be renamed to resource.map to fix the problem.

(also, I strongly recommend using a version control system).


it doesnt necessarily happen when i save a resource. sometimes it just happens as im writing something in the script, or when i create a new view. in short, just happens randomly, when i use the program.
im using the new version of SCI Companion 3, a release from 1/27/2016, in here - - http://scicompanion.com/download/
can't find ant .bak files in the folder, but ill look for one if it happens again.. maybe i deleted it at the old game's folder..

im sorry for the question - whats a version control system and how to use it?
these problems have never happened to any of you guys??

15
Hypothesis: the map and the volume don't match up.
Theory: given the raw volume without a map and something that doesn't care about the map, one might be able to extract the data and rebuild.

Test: I took The Dating Pool's copy of resource.000, put it in an isolated location away from its resource.map, and opened it in SV. I could see it all right there, without a map. Just for completeness' sake I tried a multivolume game, Conquests of Camelot, which also works fine.

More practically, SV-CLI's Resource tool can read it all mapless too, and extract everything in one go. It may be meant for command lines, but just drag and drop resource.000 or whatever onto its icon and wait. To save you the effort of finding a copy, I've attached one.


WOW, THANKS!

I really appreciate the quick reply and the help!
Downloaded the file and could see the data alright. but couldnt run the game, of course.
because i really dont know my way around computers much (thats why i wanted to try and build my own game, to see how far i could go without understanding myself what im doing... by now im pretty pleased!  :)  ) i didnt really understand much of what you advised me to do.. i just started a new game, copied all the scripts i've modified and created, loaded as much as i could of the vies and pics and created again the ones i couldnt get my hands on, and managed to rebuild my game.

thing is, im waiting for that moment when the game crashes again i lose all the data, because its been happening quite a lot...
but im saving it every other step i go, in different folders, plus the views and pics' data.
thing is, it is not normal, to go like this. i should see what i can do about it. because when im up to room 10, i wouldnt like to start the whole thing over again...


thanks for your help though!
i couldn't make it without it!

Pages: [1] 2

SMF 2.0.19 | SMF © 2021, Simple Machines
Simple Audio Video Embedder

Page created in 0.102 seconds with 21 queries.